Ionos et les versions de PHP – Une question de serveur

Category: Conseils

Mais hélas, Ionos ne vous propose pas de servir un café !  Vous me contactez souvent suite à un mail concernant la mise à jour de la version de PHP. Voici une petite explication et une indication des manipulations à effectuer.

PHP, qu’est ce que c’est ?

Votre site, votre blog ou votre boutique sont hébergés sur des serveurs. Ce sont des ordinateurs   qui fonctionnent donc avec tout un système d’exploitation et de gestion. Il y a donc en gros deux types de serveurs : les serveurs Microsoft et les serveurs Apaches.

Je gère quelques sites sur un hébergement Microsoft. Ce sont en général des sites dynamiques liés à une base de donnée de type Microsoft Access, et  pilotée par un langage appelé ASP. Les autres sites sont hébergés sur des serveurs Unix ou plus récemment Linux – la version “libre” d’Unix. Ceci existe depuis des années. Le langage utilisé est le PHP.

C’est donc ce dernier type qui est concerné.

Les mises à jour

Le langage utilisé pour faire fonctionner vos produits est du PHP, un langage de programmation libre. Comme tout produit informatique, il est fréquemment mis à jour.

Ionos vous permet donc de faire une mise à jour de votre version de PHP, et ceci site par site. En effet, en général les dernières versions passent bien, mais il peut y avoir des cas particuliers, dans des sites commerces par exemple, où une version précise de PHP est exigée.

Si pour une raison technique, vous devez rester sur une ancienne version de PHP, Ionos vous proposera une maintenance de cette version moyennant un abonnement.

Mode d’emploi

Connectez vous sur votre espace client en cliquant ici, entrez vos identifiants et cliquez sur le menu “Hébergement”

php

Vous allez ensuite cliquer sur le menu PHP – il peut déja, comme indiqué sur l’exemple, vous informer de l’utilisation du support prolongé.

Vous verrez ensuite la liste de vos domaines et sous domaines. Il suffit de cocher une ou plusieurs des cases proposées. La modification peut donc être faite pour plusieurs domaines.

php

Il est conseillé ensuite de cocher la case recommandée. Je ne vous conseille pas de prendre la version la plus récente, surtout comme ce cas ici ou l’on passe  d’une version 7  à 8. Il risque d’y avoir des beugs ou des problèmes d’incompatibilité avec des modules.

Vérifiez immédiatement votre dite dan un autre onglet – la modification est immédiate; Si le site fonctionne bien, validez votre choix par le retour à la vue d’ensemble.

 

Ensuite vérifiez si vous n’aviez pas une option de maintenance sur une ancienne version qui était lancée. Vous pouvez résilier cette option.

Remarque importante

Cette notion de version est très importante. Une mauvaise version peut avoir des répercutions sur le fonctionnement d’une boutique ou d’un blog. En effet, sont construits sur une base complexe et utilisent de nombreuses extensions. Nous avons déja pu régler des problèmes de fonctionnement en mettant à jour la version PHP du site.

Il faut savoir aussi que ces mises à jour concernent la technique mais aussi la sécurité. Au fur et à mesure que des failles sont découvertes ou exploitées par les hackers, elles sont corrigées dans les mises à jour. Soyez alors toujours vigilants.

 

Tags: php

Laisser un commentaire

Bienvenue

Inscrivez-vous à la Newsletter

Nous gardons vos données privées et ne les partageons qu’avec les tierces parties qui rendent ce service possible. Lire notre politique de confidentialité pour plus d’informations.
.